linux uhrzeit

Warum Debian? Was muss ich vorher wissen? Wo geht's nach der Installation weiter?
Antworten
happy_debian
Beiträge: 152
Registriert: 24.06.2005 21:53:02

linux uhrzeit

Beitrag von happy_debian » 24.07.2006 23:34:24

hallo

warum meine linux uhr immer 2 stunden sneller als meine windows unr?? kann man dieLinuxuhr richtig einstellen?


danke

/edit meandtheshell
ACHTUNG:
Von diesem Thread wurde wegen einer offtopic Diskussion abgespalten um Inhaltliche Konsistenz der Threads zu wahren. Hier geht es zu diesem Thread
http://www.debianforum.de/forum/viewtop ... highlight=

(Bemerkung am Rande - bei dem ganzen Thread abspalten usw. braucht man ja schon fast ein Versions Verwaltungs Tool alla SVN :D)

Benutzeravatar
meandtheshell
Beiträge: 4054
Registriert: 14.01.2005 17:51:30

Beitrag von meandtheshell » 24.07.2006 23:46:02

Schneller? - IMHO ist Zeitversetzt richtig! Das das, was Du geschrieben hast, für eine "1" in Rechtschreibung und Grammatik nicht reicht, darüber müssen wir denke ich nicht streiten ;)

Code: Alles auswählen

man date
markus

Benutzeravatar
garibaldi
Beiträge: 2440
Registriert: 17.09.2004 02:31:12
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Berlin

Beitrag von garibaldi » 25.07.2006 01:49:56

Das Problem ist meineserachtens eins der Konfiguration der Zeitzone.

Code: Alles auswählen

man tzconfig
---------------
Off Topic
---------------
Den Hinweis von meantheshell auf die Sprachregelungen solltest du schon ernst nehmen, auch wenn er selbst mal ein "s" vergisst oder ein kleines "z" großschreibt :wink:

Faustregel:
Je mehr Mühe du dir bei der Formulierung deiner Fragen gibst, desto verständlicher sind sie und desto mehr Beachtung finden sie auch.

Mal ein wenig übertrieben, aber nicht ganz realitätsfern:
wendu dir durc en sat wie dise durharbtn mst vergäht dr snel luft
-------------

Gruß, garibaldi

_mh_
Beiträge: 171
Registriert: 10.07.2006 11:52:28

Beitrag von _mh_ » 25.07.2006 10:15:26

Hallo,

meines erachtens war das immer das Problem dass sich windows nicht wirklich darum schert dass hardwarezeit != Systemzeit ist und die Zeit immer auf GMT + 1 setzt (fuer deutschland). Das Linux jetzt erwartet dass die Systemzeit auf GMT gesetzt ist (so isses zumindest standardmaessig eingestellt) und addiert noch eins drauf (weil GMT + 1 in Deutschland).

Ploetzlich hat man dann 2 Stunden Differenz im Linux sobald man ausm Windows ins Linux umbootet. Am besten mittels base-config (mein ich dass es da ging) oder vielleicht auch via tzconfig (siehe garibaldi's Post) einzustellen.

Benutzeravatar
garibaldi
Beiträge: 2440
Registriert: 17.09.2004 02:31:12
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Berlin

Beitrag von garibaldi » 25.07.2006 10:23:47

Dort gab's das Problem der verschiedenen Uhrzeiten Win/Lin auch schon einmal und wurde gelöst:

http://www.debianforum.de/forum/viewtopic.php?t=68808

Benutzeravatar
voyager
Beiträge: 90
Registriert: 13.07.2006 23:00:32

Beitrag von voyager » 25.07.2006 11:58:12

Danke an Kelpin u. garibaldi!
das war's u. anschließend die Uhr nochmals stellen, dann stimmt's in Windows u. in Linux.
man tzconfig
enthält auch den richtigen Hinweis, aber halt nur in Englisch.

Gruß, voyager

Benutzeravatar
garibaldi
Beiträge: 2440
Registriert: 17.09.2004 02:31:12
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Berlin

Beitrag von garibaldi » 25.07.2006 12:13:22

@voyager(=happy_debian?): Fein, das es geklappt hat.

@Kelpin: Schau mal hier. Doppelt hält besser! :D

Benutzeravatar
voyager
Beiträge: 90
Registriert: 13.07.2006 23:00:32

Beitrag von voyager » 25.07.2006 12:22:35

garibaldi hat geschrieben:@voyager(=happy_debian?)
Nee, ich hatte nur das selbe Problem.

Gruß, voyager

nonoo

oh Super

Beitrag von nonoo » 02.01.2007 22:12:08

Ich hatte das gleiche Systemzeitproblem,

vielen Dank.

Code: Alles auswählen


#
# /etc/default/rcS
#
# Default settings for the scripts in /etc/rcS.d/
#
# For information about these variables see the rcS(5) manual page.
#
# This file belongs to the "initscripts" package.

TMPTIME=0
SULOGIN=no
DELAYLOGIN=no
UTC=no
VERBOSE=no
FSCKFIX=no
RAMRUN=no
RAMLOCK=no
So ist die Datei für mich richtig.

Systemzeit einstellen, konfigurieren


Schöne Grüße

nonoo

Steffent
Beiträge: 154
Registriert: 29.10.2002 01:10:38
Wohnort: Döbeln

Beitrag von Steffent » 11.03.2007 13:52:26

Bei mir hat das nur geklappt, nachdem ich mir einen eigen Kernel für Etch gebacken habe.
Für mich stellt sich aber die Frage.
Warum tritt dieses Problem mit der Uhrzeit bei Etch auf ? Bei Woody und Sarge kannte ich das so nicht.
Habe Sarge seit Sep. 2004 auf der Platte und nie Probleme mit der Uhrzeit.
Nun eben mal Etch auf Parallelplatte ausprobiert und eben dieses Problem.

Nicolas
Beiträge: 28
Registriert: 12.10.2003 14:32:47

Beitrag von Nicolas » 19.03.2007 21:36:11

Also ich hab mir erst vor kurzem wieder Windows dazu installiert und nicht Linux sondern Windows angepasst:

Code: Alles auswählen

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
"RealTimeIsUniversal"=dword:00000001

cosmac
Beiträge: 4562
Registriert: 28.03.2005 22:24:30

Beitrag von cosmac » 19.03.2007 22:38:10

@Nicolas: das war jetzt der beste Beitrag zum Uhrzeit-Problem seit 12 noon 1 JAN -4712 :!:
Danke ! :D

@Steffent: Das mit dem selbstgebauten Kernel halte ich für extrem unwahrscheinlich.
Im wirklichen Leben hast du es immer mit mehreren Fehlern gleichzeitig zu tun.
Evt. liegt es daran, daß Sarge noch mit dem korrekten Default "UTC=yes"
installariert wurde, und der bei Etch zu "UTC=no" geändert wurde.

Weil man die Meckerei der Windows-User satt hatte und Nicolas' Tipp noch nicht kannte.
Beware of programmers who carry screwdrivers.

Antworten