Buster: PackageKit / package-update-indicator akzeptiert kein Passwort

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Benutzeravatar
willy4711
Beiträge: 2526
Registriert: 08.09.2018 16:51:16

Re: Buster: PackageKit / package-update-indicator akzeptiert kein Passwort

Beitrag von willy4711 » 28.10.2019 20:20:45

rockyracoon hat geschrieben: ↑ zum Beitrag ↑
28.10.2019 19:14:24
Willy4711, Du kannst wohl immer noch nicht verstehen oder akzeptieren, dass sich der Update-Indikator offentsichtlich unter XFCE anders verhält, als unter Gnome3.
Warum sollte er das? ist doch wohl dasselbe Paket? Man muss ihn halt nur erlauben, sich im Paneel anzusiedeln,
vorzugsweise mit Debiangnome-shell-extension-top-icons-plus
rockyracoon hat geschrieben: ↑ zum Beitrag ↑
28.10.2019 19:14:24
Was soll der Thread-Starter "debianoli" mit Deinem Post also produktiv anfangen?
debianoli hat geschrieben: ↑ zum Beitrag ↑
28.10.2019 10:55:49
ich habe den Laptop eines Freunds auf Buster (XFCE-Desktop) geupgraded und dazu noch Debianpackage-update-indicator installiert.
Er hat Xfce und ich auch. Der von mir verlinkte Thread handelt auch über Xfce. Ist doch dann anwendbar ?

Benutzeravatar
willy4711
Beiträge: 2526
Registriert: 08.09.2018 16:51:16

Re: Buster: PackageKit / package-update-indicator akzeptiert kein Passwort

Beitrag von willy4711 » 28.10.2019 20:38:54

Nur noch ne Ergänzung:
Das Script von hier viewtopic.php?t=172036#p1210886
funktioniert mit tilx nicht mehr. Tilix hat z.Z. einen Bug. [1]
deshalb unter Xfce umstellen auf Debianxfce4-terminal und einen entsprechende policy dafür erstellen.

Code: Alles auswählen

#!/bin/bash

pkexec xfce4-terminal -e "aptitude update"
pkexec xfce4-terminal -e "aptitude full-upgrade" 
geany /var/log/aptitude

exit
[1][deb]https://bugs.debian.org/cgi-bin/bugrepo ... bug=940849[/deb]

Benutzeravatar
rockyracoon
Beiträge: 519
Registriert: 13.05.2016 12:42:18
Wohnort: Tír Tairngiri

Re: Buster: PackageKit / package-update-indicator akzeptiert kein Passwort

Beitrag von rockyracoon » 28.10.2019 21:13:47

@willy4711:
Nur noch ne Ergänzung:
Das Script von hier viewtopic.php?t=172036#p1210886
funktioniert mit tilx nicht mehr. Tilix hat z.Z. einen Bug. [1]
deshalb unter Xfce umstellen auf Debianxfce4-terminal und einen entsprechende policy dafür erstellen.

Code: Alles auswählen

#!/bin/bash

pkexec xfce4-terminal -e "aptitude update"
pkexec xfce4-terminal -e "aptitude full-upgrade"
geany /var/log/aptitude

exit

[1][deb]https://bugs.debian.org/cgi-bin/bugrepo ... bug=940849[/deb]
Und das soll eine einfache Problemlösung sein, das soll dem Thread-Starter debianoli helfen? :facepalm:
Einfacher, als von XFCE auf Gnome3 zu wechseln, "Apt Update Indicator" als Erweiterung wählen und Alles funktioniert wie es soll, ohne Deine zugegeben kunstvolle Bastellösung?
Zuletzt geändert von rockyracoon am 28.10.2019 22:30:01, insgesamt 5-mal geändert.

Benutzeravatar
willy4711
Beiträge: 2526
Registriert: 08.09.2018 16:51:16

Re: Buster: PackageKit / package-update-indicator akzeptiert kein Passwort

Beitrag von willy4711 » 28.10.2019 21:27:25

8O :twisted: :twisted: 8O 8O 8O 8O 8O 8O :?: :!:
Einfach Klappe halten

debianoli
Beiträge: 3539
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: Buster: PackageKit / package-update-indicator akzeptiert kein Passwort

Beitrag von debianoli » 31.10.2019 10:04:20

@all
Danke soweit für die Hinweise, ich teste das die nächsten Tage, wenn ich bei meinem Freund bin.

Benutzeravatar
kalle123
Beiträge: 900
Registriert: 28.03.2015 12:27:47
Wohnort: Mönchengladbach

Re: Buster: PackageKit / package-update-indicator akzeptiert kein Passwort

Beitrag von kalle123 » 31.10.2019 11:35:30

Hab mir das mal unter Testing angeschaut. Da soll also 'irgendwann' mal kurz eine Benachrichtigung (pop-up) kommen, dass updates da sind. :(

Ist nicht das, was mit hilft. Bin davon ausgegangen, dass das Icon im Launcher irgendwie abgeändert wird, falls updates da sind. Ich hock nicht vor der Kiste und schau gebannt auf den screen, ob da jetzt was kommt.

Also weiterhin Synaptic! Oder hab ich was falsch verstanden?

cu KH
ASUS PRIME X370-A + AMD Ryzen 5-2600, GeForce GT1030 16GB , DEBIAN-Buster Xfce
ASUS P5QL + Intel Core2 Duo E6750, GeForce GT710, 8GB, DEBIAN Testing Xfce
Lenovo Thinkpad T450s, DEBIAN Testing Xfce

Benutzeravatar
willy4711
Beiträge: 2526
Registriert: 08.09.2018 16:51:16

Re: Buster: PackageKit / package-update-indicator akzeptiert kein Passwort

Beitrag von willy4711 » 31.10.2019 11:52:55

kalle123 hat geschrieben: ↑ zum Beitrag ↑
31.10.2019 11:35:30
Ist nicht das, was mit hilft. Bin davon ausgegangen, dass das Icon im Launcher irgendwie abgeändert wird, falls updates da sind. Ich hock nicht vor der Kiste und schau gebannt auf den screen, ob da jetzt was kommt.
Ich hatte deswegen mit dem Entwickler korrespondiert:
> I think, from the debug-Log I found the problem.
>
> Not all icon themes have different icons for
> "system-software-update" and "software-update-available".
>
> In my mail, I had the Papirus icon theme in use,that offers no different
> icons.
>
>
> I think to solve the problem, it would be only possible if there were own
> icons.
> The two links are screen shots from the icons available to me for both
> options.
>
> Very big and long but it could not be otherwise.
> In the appendix the two logs.
>
> I think the bug report you gave me has a different theme.
> Let me know if I should make a new one. (would be the first time for me :-D)

yes, from the debug log everything seems fine. Not having different
icons for "system-software-update" and "software-update-available" is
indeed a problem. I don't want to supply custom icons because I
think they should follow the users theme so they do not look out of
place in the panel and both XFCE/GNOME- and KDE-based themes already
supply these for their own indicators. So the only solution I can
suggest is to either try to convince the theme author to create a
separate icon for "system-software-update" or to use a different theme
which does not have this problem.
Hope this helps,
--
Guido Berhoerster
Die Lösung ist, dass man entweder sehen muss, ein Icon-Theme zu erwischen, dass für

system-software-update" and "software-update-available

unterschiedlich Icons hat, oder man kreiert sich was Eigenes:
hab mit mein Standard- Theme (Moka) nach ~/.icons/Willy-Moka
kopiert und dort zwei unterschiedliche Icons dafür angelegt.
Ergebnis war ja zu sehen. :mrgreen:

Das Ergebnis in dem Verzeichnissen:
Allerdings weiß ich nicht mehr von welchem Icon-Theme ich mir das geklaut hatte :facepalm: :

Code: Alles auswählen

find ~/.icons/Willy-Moka/ -name *software-update-available*|sort
/home/willy/.icons/Willy-Moka/16x16@2x/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/16x16/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/16x16/status/software-update-available.png
/home/willy/.icons/Willy-Moka/22x22@2x/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/22x22/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/22x22/status/software-update-available.png
/home/willy/.icons/Willy-Moka/24x24@2x/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/24x24@2x/status/software-update-available.png
/home/willy/.icons/Willy-Moka/24x24/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/256x256@2x/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/256x256/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/32x32@2x/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/32x32/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/32x32/status/software-update-available.png
/home/willy/.icons/Willy-Moka/48x48@2x/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/48x48/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/64x64@2x/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/64x64/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/96x96@2x/apps/software-update-available.png
/home/willy/.icons/Willy-Moka/96x96/apps/software-update-available.png
und

Code: Alles auswählen

find ~/.icons/Willy-Moka/ -name *system-software-update*|sort
/home/willy/.icons/Willy-Moka/16x16@2x/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/16x16/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/22x22@2x/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/22x22/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/24x24@2x/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/24x24/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/256x256@2x/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/256x256/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/32x32@2x/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/32x32/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/48x48@2x/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/48x48/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/64x64@2x/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/64x64/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/96x96@2x/apps/system-software-update.png
/home/willy/.icons/Willy-Moka/96x96/apps/system-software-update.png

Benutzeravatar
rockyracoon
Beiträge: 519
Registriert: 13.05.2016 12:42:18
Wohnort: Tír Tairngiri

Re: Buster: PackageKit / package-update-indicator akzeptiert kein Passwort

Beitrag von rockyracoon » 31.10.2019 15:15:11

...ist aber eine von dir kreierte Bastellösung...
>>> 8O

Benutzeravatar
willy4711
Beiträge: 2526
Registriert: 08.09.2018 16:51:16

Re: Buster: PackageKit / package-update-indicator akzeptiert kein Passwort

Beitrag von willy4711 » 31.10.2019 15:19:57

Lass es doch einfach sein.
Hab ich jemals behauptet, dass ich nicht bastele ?
Nein, macht halt Spass.
Genauso kann man in Gnome basteln und in jeder anderen Oberfläche.
Ist halt dann nicht mehr Oberflächen- typisch, was der Ausgangspunkt des Streites war.
Und nochmal:
Wir unterhalten uns hier nicht über Gnome sondern über ein Programm unter Xfce.
Bereits der dritte Beitrag in diesem Thread war:
debianoli hat geschrieben: ↑ zum Beitrag ↑
28.10.2019 17:08:58
Danke für die konstruktive Antwort.
Vielleicht mal danach richten ?

Benutzeravatar
rockyracoon
Beiträge: 519
Registriert: 13.05.2016 12:42:18
Wohnort: Tír Tairngiri

Re: Buster: PackageKit / package-update-indicator akzeptiert kein Passwort

Beitrag von rockyracoon » 31.10.2019 15:26:07

@willy4711:
Hab ich jemals behauptet, dass ich nicht bastele ?
Nein, macht halt Spass.
So kann ich es akzeptieren und bin gerne zu:
Lass es doch einfach sein.
bereit. :THX:

Mir liegt sehr viel daran, dass Anfragen in unserem Forum gut beantwortet werden.
In diesem Sinn sollten wir zusammenarbeiten, statt uns unnötig zu nerven.


Benutzeravatar
kalle123
Beiträge: 900
Registriert: 28.03.2015 12:27:47
Wohnort: Mönchengladbach

Re: Buster: PackageKit / package-update-indicator akzeptiert kein Passwort

Beitrag von kalle123 » 31.10.2019 15:55:48

@willy4711.

Dank dir für die umfangreiche Antwort. Mit dem wechselnden panel icon kenn ich das von anderen distros her.
Werde mich noch mal dran setzten. :D

Grüße KH
ASUS PRIME X370-A + AMD Ryzen 5-2600, GeForce GT1030 16GB , DEBIAN-Buster Xfce
ASUS P5QL + Intel Core2 Duo E6750, GeForce GT710, 8GB, DEBIAN Testing Xfce
Lenovo Thinkpad T450s, DEBIAN Testing Xfce

Antworten