gelöst Hylafax Installation scheitert in Debian

Einrichten des Druckers und des Drucksystems, Scannerkonfiguration und Software zum Scannen und Faxen.
Antworten
Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

gelöst Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 10.09.2022 17:36:04

Hallo an alle Wissenden,
mich treibt immer noch ein Fehler in Hylafax um.
Ich vermute das bei der Installation etwas schief läuft.

Ich bekomme nach Eingabe von "faxsetup" folgende Ausgabe:

Code: Alles auswählen

Setup program for HylaFAX (tm) 7.0.5.

Created for x86_64-unknown-linux-gnu on Sun Dec  5 04:53:43 UTC 2021.

Found encoder: /bin/base64
Found encoder: /bin/uuencode
Looks like /bin/base64 supports base64 encoding.
Checking system for proper client configuration.
Checking system for proper server configuration.


Setting Ghostscript font path in /usr/local/lib/fax/hyla.conf.



Warning: Font metric information files were not found!

The font metric information file for the Courier font was not found in
the /usr/share/ghostscript/9.53.3/Resource/Init:/usr/share/ghostscript/9.53.3/lib:/usr/share/ghostscript/9.53.3/Resource/Font:/usr/share/ghostscript/fonts:/var/lib/ghostscript/fonts:/usr/share/cups/fonts:/usr/share/ghostscript/fonts:/usr/local/lib/ghostscript/fonts:/usr/share/fonts:/usr/share/ghostscript/9.53.3/Resource/Init:/usr/share/ghostscript/9.53.3/lib:/usr/share/ghostscript/9.53.3/Resource/Font:/usr/share/ghostscript/fonts:/var/lib/ghostscript/fonts:/usr/share/cups/fonts:/usr/share/ghostscript/fonts:/usr/local/lib/ghostscript/fonts:/usr/share/fonts path.  This means that client HylaFAX applications 
that use this information to format ASCII text for submission as fax will
use incorrect information and generate potentially illegible facsimile.

If font metric information is present on your system in a directory other
than /usr/share/ghostscript/9.53.3/Resource/Init:/usr/share/ghostscript/9.53.3/lib:/usr/share/ghostscript/9.53.3/Resource/Font:/usr/share/ghostscript/fonts:/var/lib/ghostscript/fonts:/usr/share/cups/fonts:/usr/share/ghostscript/fonts:/usr/local/lib/ghostscript/fonts:/usr/share/fonts:/usr/share/ghostscript/9.53.3/Resource/Init:/usr/share/ghostscript/9.53.3/lib:/usr/share/ghostscript/9.53.3/Resource/Font:/usr/share/ghostscript/fonts:/var/lib/ghostscript/fonts:/usr/share/cups/fonts:/usr/share/ghostscript/fonts:/usr/local/lib/ghostscript/fonts:/usr/share/fonts then you can setup a symbolic link to the appropriate
directory or you can specify the appropriate pathname in the configuration
file /usr/local/lib/fax/hyla.conf with a line of the form:

FontPath:	someplace_unexpected


Make /var/spool/hylafax/bin/ps2fax a link to /var/spool/hylafax/bin/ps2fax.gs.


Make /var/spool/hylafax/bin/pdf2fax a link to /var/spool/hylafax/bin/pdf2fax.gs.

Update /var/spool/hylafax/status/any.info.
Leider ist mein Englisch sehr überschaubar. Kann mir hier jemand weiter helfen?

Danke Gruß Xante
Zuletzt geändert von Xantorix am 13.03.2023 22:29:28, insgesamt 1-mal geändert.

AxelMD
Beiträge: 1398
Registriert: 15.03.2009 08:02:11

Re: Hylafax Installation scheitert in Debian

Beitrag von AxelMD » 10.09.2022 18:52:58

Hallo Xante,

arbeite das doch mal durch, wenn nicht geschehen:

https://wiki.debian.org/HylaFax#Installation

Bullseye - Hylafax Server startet nicht
viewtopic.php?t=181906

P.S. Du bist in die falsch Abteilung gerutscht.

MfG
AxelMD

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 10.09.2022 19:14:34

Sorry das habe ich schon alles durch und noch mehr. Deshalb glaube ich ja das es an der Installation von hylafax liegt.

Ich habe bei "faxsetup" erstmal abgebrochen. Die oben beschriebnen Probleme möchte ich erst lösen.

Danke Gruß Xante

AxelMD
Beiträge: 1398
Registriert: 15.03.2009 08:02:11

Re: Hylafax Installation scheitert in Debian

Beitrag von AxelMD » 10.09.2022 19:17:02

hylafax-server (3:6.0.6-8.1)

https://packages.debian.org/buster/hylafax-server

Dein Paket hast Du dir vermutlich selber gebaut.

HylaFAX (tm) 7.0.5 ist nicht in den Reporsitorys.

https://www.hylafax.org/

Noch nicht mal in Debian sid.

Versuche es doch erst mit hylafax-server (3:6.0.6-8.1).

Woher hast Du dein hylafax?

https://hylafax.sourceforge.io/

https://hylafax.sourceforge.io/howto/install.php#ss2.3
If HylaFAX binaries are available for your environment, many times installing them will prove to be much easier than performing a source installation. Also, binary installations generally will provide a more uniform installation layout similar to other packages already on the system. A binary installation generally maintains the integrity of the system's package management system, especially in the case of RPM, which gives good vigilence over conflicts, requirements, and makes upgrading or uninstallations simple. So, if current HylaFAX binaries are available for your environment, it is generally recommended to use them or make them yourself for installation.
Das empfehlen die Entwickler, dein Problem zu lösen ist vermutlich nichts für Anfänger.

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 10.09.2022 19:38:13

Stimmt das aktuelle ist nicht aus den Quellen.
Doch bei der Version aus Debian treten genau die selben Probleme auf.
Deshalb habe ich versuchsweise hylafax mit samt Einstellungen entfernt und ein neues kompiliert.
Meine konkreten Fragen bezüglich der Konsolenausgaben und evtl. Lösungsvorschläge sind also identisch mit der Debian Version.
Gerne installiere ich diese wieder.

Hat jemand zu den oben geschriebenen Meldungen nach "faxsetup" Eingabe etwas hilfreiches?

Danke Xante

AxelMD
Beiträge: 1398
Registriert: 15.03.2009 08:02:11

Re: Hylafax Installation scheitert in Debian

Beitrag von AxelMD » 10.09.2022 20:08:24

Es sieht nicht gut aus, um Hylafax scheint sich niemand zu kümmern.

Fehlerberichte:
https://bugs.debian.org/cgi-bin/pkgrepo ... t=unstable

sehr sehr alt


sourceforge net / projects / hylafax /
https://sourceforge.net/projects/hylafax/

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 10.09.2022 20:19:32

Hab ich auch schon gemerkt. Schade ich hätt es gern wieder am laufen.
Bis buster ging das ganze.

JTH
Moderator
Beiträge: 3026
Registriert: 13.08.2008 17:01:41
Wohnort: Berlin

Re: Hylafax Installation scheitert in Debian

Beitrag von JTH » 10.09.2022 20:25:02

Xantorix hat geschrieben: ↑ zum Beitrag ↑
10.09.2022 17:36:04
Warning: Font metric information files were not found!

The font metric information file for the Courier font was not found in
the /usr/share/ghostscript/9.53.3/Resource/Init:/usr/share/ghostscript/9.53.3/lib:/usr/share/ghostscript/9.53.3/Resource/Font:/usr/share/ghostscript/fonts:/var/lib/ghostscript/fonts:/usr/share/cups/fonts:/usr/share/ghostscript/fonts:/usr/local/lib/ghostscript/fonts:/usr/share/fonts:/usr/share/ghostscript/9.53.3/Resource/Init:/usr/share/ghostscript/9.53.3/lib:/usr/share/ghostscript/9.53.3/Resource/Font:/usr/share/ghostscript/fonts:/var/lib/ghostscript/fonts:/usr/share/cups/fonts:/usr/share/ghostscript/fonts:/usr/local/lib/ghostscript/fonts:/usr/share/fonts path. This means that client HylaFAX applications
that use this information to format ASCII text for submission as fax will
use incorrect information and generate potentially illegible facsimile.
Die bemängelten Fontmetriken müssten – den Pfaden und dem Inhalt des folgenden Pakets nach – aus Debiangsfonts stammen. Ist das installiert? Da du Hylafax anscheinend selbst gebaut hast, ist es evtl. nicht wie normalerweise als Abhängigkeit mitgekommen.
Manchmal bekannt als Just (another) Terminal Hacker.

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 10.09.2022 21:00:39

Neu alte Situation. Ich habe alles neu aus den Paketquellen installiert.

Jetzt läuft "faxsetup" bis zum "Probing for best speed to talk to modem: 38400"

Dann hängt es sich auf. Hatte ich auch früher schon mal. In welchem log kann ich da schauen?

P.S. Wie gesagt bis buster war alles schick. Hab mir jetzt provisorisch eine Buster version auf einen alten Raspberry Pi gemacht. Hätte es aber gerne wieder in meinem Hauptserver.

JTH
Moderator
Beiträge: 3026
Registriert: 13.08.2008 17:01:41
Wohnort: Berlin

Re: Hylafax Installation scheitert in Debian

Beitrag von JTH » 10.09.2022 21:23:34

Xantorix hat geschrieben: ↑ zum Beitrag ↑
10.09.2022 21:00:39
In welchem log kann ich da schauen?
Im Zweifelsfall immer erst mal im Journal (mit journalctl). Aber ich nehme stark an, dass da nichts besonderes drinsteht. faxsetup hat eine Option --verbose. Liefert die zusätzliches Hilfreiches?
Manchmal bekannt als Just (another) Terminal Hacker.

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 10.09.2022 21:39:32

- verbose zeigt auch nichts an. Leider.

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 15.10.2022 14:01:05

Hallo, ich muss das ganze noch mal hoch holen.
Vielleicht kann ja doch jemand helfen.

Ich habe den Debianserver neu aufgesetzt. Es ist Debian 11 drauf und alles aus den Paketquellen mit apt installiert.

Definitiv bleibt die hylafax Installation "faxsetup" am Ende beim Modemtest hängen und lässt sich auch nicht mit STRG + c beenden.
Ein "faxsetup -- verbose" zeigt keinerlei Informationen und bleibt auch beim Modemtest hängen.
Ein "sudo systemctl status asterisk" bringt:

Code: Alles auswählen

● asterisk.service - Asterisk PBX
     Loaded: loaded (/lib/systemd/system/asterisk.service; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2022-10-14 21:57:28 CEST; 15h ago
       Docs: man:asterisk(8)
   Main PID: 1218 (asterisk)
      Tasks: 67 (limit: 8844)
     Memory: 70.8M
        CPU: 25min 12.704s
     CGroup: /system.slice/asterisk.service
             ├─1218 /usr/sbin/asterisk -g -f -p -U asterisk
             └─1225 astcanary /var/run/asterisk/alt.asterisk.canary.tweet.tweet.tweet 1218

Okt 14 21:57:28 omv-office asterisk[1218]: Asterisk Ready.
Okt 14 21:57:28 omv-office systemd[1]: Started Asterisk PBX.
Okt 14 21:57:28 omv-office asterisk[1218]: [Oct 14 21:57:28] WARNING[1370]: chan_sip.c:3837 __sip_xmit: sip_xmit of 0x7f9db00017b0 (len 409) to (null) returned -1: Invalid argument
Okt 14 21:57:29 omv-office asterisk[1218]: [Oct 14 21:57:29] WARNING[1370]: chan_sip.c:3837 __sip_xmit: sip_xmit of 0x7f9db00017b0 (len 409) to (null) returned -1: Invalid argument
Okt 14 21:57:31 omv-office asterisk[1218]: [Oct 14 21:57:31] WARNING[1370]: chan_sip.c:3837 __sip_xmit: sip_xmit of 0x7f9db00017b0 (len 409) to (null) returned -1: Invalid argument
Okt 14 21:57:35 omv-office asterisk[1218]: [Oct 14 21:57:35] WARNING[1370]: chan_sip.c:3837 __sip_xmit: sip_xmit of 0x7f9db00017b0 (len 409) to (null) returned -1: Invalid argument
Okt 14 21:57:39 omv-office asterisk[1218]: [Oct 14 21:57:39] WARNING[1370]: chan_sip.c:3837 __sip_xmit: sip_xmit of 0x7f9db00017b0 (len 409) to (null) returned -1: Invalid argument
Okt 14 21:57:43 omv-office asterisk[1218]: [Oct 14 21:57:43] WARNING[1370]: chan_sip.c:3837 __sip_xmit: sip_xmit of 0x7f9db00017b0 (len 409) to (null) returned -1: Invalid argument
Okt 14 21:57:47 omv-office asterisk[1218]: [Oct 14 21:57:47] WARNING[1370]: chan_sip.c:3837 __sip_xmit: sip_xmit of 0x7f9db00017b0 (len 409) to (null) returned -1: Invalid argument
Okt 14 21:57:48 omv-office asterisk[1218]: [Oct 14 21:57:48] NOTICE[1370]: chan_sip.c:16041 sip_reg_timeout:    -- Registration for 'asterisk@fritz.box' timed out, trying again (Attempt #2)
Ein "sudo systemctl status iaxmodem" bringt:

Code: Alles auswählen

● iaxmodem.service - LSB: Software modem with IAX2 connectivity
     Loaded: loaded (/etc/init.d/iaxmodem; generated)
     Active: active (running) since Fri 2022-10-14 21:57:28 CEST; 15h ago
       Docs: man:systemd-sysv-generator(8)
    Process: 1432 ExecStart=/etc/init.d/iaxmodem start (code=exited, status=0/SUCCESS)
      Tasks: 2 (limit: 8844)
     Memory: 860.0K
        CPU: 2.303s
     CGroup: /system.slice/iaxmodem.service
             ├─1438 /usr/bin/iaxmodem
             └─1440 /usr/bin/iaxmodem

Okt 14 21:57:28 omv-office systemd[1]: Starting LSB: Software modem with IAX2 connectivity...
Okt 14 21:57:28 omv-office iaxmodem[1432]: Starting iaxmodem: iaxmodem.
Okt 14 21:57:28 omv-office systemd[1]: Started LSB: Software modem with IAX2 connectivity.
Mit gleichen Parametern in Debian 10 funktioniert es einwandfrei.
Vielleicht kann ja noch mal jemand mit Ahnung drüber schauen.

Ich vermute irgendwas mit systemd. Aber meine Kenntnisse sind halt sehr überschaubar.

Gruß Xante

Benutzeravatar
GregorS
Beiträge: 2690
Registriert: 05.06.2008 09:36:37
Wohnort: Freiburg
Kontaktdaten:

Re: Hylafax Installation scheitert in Debian

Beitrag von GregorS » 15.10.2022 14:23:46

Xantorix hat geschrieben: ↑ zum Beitrag ↑
15.10.2022 14:01:05
...Mit gleichen Parametern in Debian 10 funktioniert es einwandfrei.
Wieso belässt Du es dann nicht bei Debian 10? Ist das kein „Fax-only-standalone-System“?

Gruß

Gregor
Wenn man keine Probleme hat, kann man sich welche machen. ("Großes Lötauge", Medizinmann der M3-Hopi [und sog. Maker])

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 15.10.2022 14:29:21

Genau das ist ja das Problem. Die Faxlösung ist nur ein kleiner Teil des Servers.
Ich habe mir ja parallel mit einem Raspberry Pi geholfen.
Aber den möchte ich wieder weg packen.

Benutzeravatar
GregorS
Beiträge: 2690
Registriert: 05.06.2008 09:36:37
Wohnort: Freiburg
Kontaktdaten:

Re: Hylafax Installation scheitert in Debian

Beitrag von GregorS » 15.10.2022 16:02:04

Xantorix hat geschrieben: ↑ zum Beitrag ↑
15.10.2022 14:29:21
Genau das ist ja das Problem. Die Faxlösung ist nur ein kleiner Teil des Servers.
Ich habe mir ja parallel mit einem Raspberry Pi geholfen.
Aber den möchte ich wieder weg packen.
Hm. Vielleicht wäre es dann besser, auf Fax zu verzichten. So irre fortschrittlich ist das ja nun eh nicht ...

Wenn es im Kern um vertrauliche Kommunikation geht, wäre es dann nicht besser, auf PGP zu „upgraden“?

Gruß

Gregor
Wenn man keine Probleme hat, kann man sich welche machen. ("Großes Lötauge", Medizinmann der M3-Hopi [und sog. Maker])

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 15.10.2022 16:14:06

Klar alles möglich. Doch möchte ich das Problem lösen.
Es muss doch einen Grund geben warum faxsetup nicht durch läuft.

JTH
Moderator
Beiträge: 3026
Registriert: 13.08.2008 17:01:41
Wohnort: Berlin

Re: Hylafax Installation scheitert in Debian

Beitrag von JTH » 15.10.2022 17:50:07

Schauen wir doch mal …

Xantorix hat geschrieben: ↑ zum Beitrag ↑
15.10.2022 14:01:05
Ich vermute irgendwas mit systemd.
Ich würd da eher eine Veränderung in der notwendigen Konfiguration oder ungünstigenfalls einen neuen Bug vermuten.

Vielleicht kann ja noch mal jemand mit Ahnung drüber schauen.
Konkret von dem Problem hab ich die nicht, aber ein offenes Auge bei der Fehlersuche ;)

Xantorix hat geschrieben: ↑ zum Beitrag ↑
15.10.2022 14:01:05
Ein "faxsetup -- verbose" zeigt keinerlei Informationen und bleibt auch beim Modemtest hängen.
Na, der Aufruf ohne das --verbose hat doch schon was ausgegeben, mit wird doch wenigstens das gleiche herauskommen, wenn ja – zeig das doch (noch)mal.

Xantorix hat geschrieben: ↑ zum Beitrag ↑
15.10.2022 14:01:05

Code: Alles auswählen

Okt 14 21:57:47 omv-office asterisk[1218]: [Oct 14 21:57:47] WARNING[1370]: chan_sip.c:3837 __sip_xmit: sip_xmit of 0x7f9db00017b0 (len 409) to (null) returned -1: Invalid argument
Okt 14 21:57:48 omv-office asterisk[1218]: [Oct 14 21:57:48] NOTICE[1370]: chan_sip.c:16041 sip_reg_timeout:    -- Registration for 'asterisk@fritz.box' timed out, trying again (Attempt #2)
Das kommt mir erstmal auffällig vor. Ich kenn mich mit der Thematik hier allerdings höchstens vage aus. Die Kette, die hier zusammenarbeitet ist: asterisk <-> iaxmodem <-> hylafax?

Wenn ich eine Suchmaschine nach

Code: Alles auswählen

__sip_xmit: sip_xmit of len to (null) returned -1: Invalid argument
frage, deutet einiges darauf hin, dass die Asterisk-Konfiguration nicht korrekt funktionieren könnte, das Netzwerk/Internet nicht richtig erreichbar ist oder ne Firewall im Weg steht. Hast du das mal überprüft?
Manchmal bekannt als Just (another) Terminal Hacker.

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 15.10.2022 18:13:45

Danke.
Hab ich noch nicht geprüft aber die Warnungen keine Error hatte ich in Debian 10 auch ohne Probleme.

Habe gerade mal zum testen efax auf den Server gemacht.

Also das IAXmodem funktioniert und es lässt sich auch mit efax ein Fax absenden.
Natürlich kann ich damit nur testen und nicht komfortabel im Netzwerk arbeiten.

Ich versuche mal die Warnungen im Asterisk zu entstören aber wenn es mit efax geht vermute ich den Fehler in hylafax.

Status bei asterisk und Iaxmodenm ist grün. hylafax lässt sich nicht fertig installieren.

"faxsetup" bleibt beim Modemtest hängen.

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 15.10.2022 19:35:40

Hallo, so sieht es jetzt aus.

Code: Alles auswählen

● asterisk.service - Asterisk PBX
     Loaded: loaded (/lib/systemd/system/asterisk.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2022-10-15 19:31:29 CEST; 5s ago
       Docs: man:asterisk(8)
   Main PID: 2401 (asterisk)
      Tasks: 78 (limit: 8844)
     Memory: 38.7M
        CPU: 3.353s
     CGroup: /system.slice/asterisk.service
             ├─2401 /usr/sbin/asterisk -g -f -p -U asterisk
             └─2403 astcanary /var/run/asterisk/alt.asterisk.canary.tweet.tweet.tweet 2401

Okt 15 19:31:29 omv-office asterisk[2401]: [Oct 15 19:31:29] ERROR[2401]: loader.c:2396 load_modules: cdr_radius declined to load.
Okt 15 19:31:29 omv-office asterisk[2401]: [Oct 15 19:31:29] ERROR[2401]: loader.c:2396 load_modules: cel_sqlite3_custom declined to load.
Okt 15 19:31:29 omv-office asterisk[2401]: [Oct 15 19:31:29] ERROR[2401]: loader.c:2396 load_modules: cel_tds declined to load.
Okt 15 19:31:29 omv-office asterisk[2401]: [Oct 15 19:31:29] ERROR[2401]: loader.c:2396 load_modules: cdr_sqlite3_custom declined to load.
Okt 15 19:31:29 omv-office asterisk[2401]: [Oct 15 19:31:29] ERROR[2401]: loader.c:2396 load_modules: chan_unistim declined to load.
Okt 15 19:31:29 omv-office asterisk[2401]: [Oct 15 19:31:29] ERROR[2401]: loader.c:2396 load_modules: pbx_dundi declined to load.
Okt 15 19:31:29 omv-office asterisk[2401]: [Oct 15 19:31:29] ERROR[2401]: loader.c:2396 load_modules: res_hep_rtcp declined to load.
Okt 15 19:31:29 omv-office asterisk[2401]: [Oct 15 19:31:29] ERROR[2401]: loader.c:2396 load_modules: res_hep_pjsip declined to load.
Okt 15 19:31:29 omv-office asterisk[2401]: Asterisk Ready.
Okt 15 19:31:29 omv-office systemd[1]: Started Asterisk PBX.
"faxsetup" bricht immer noch hier ab:

Code: Alles auswählen

Probing for best speed to talk to modem: 38400

JTH
Moderator
Beiträge: 3026
Registriert: 13.08.2008 17:01:41
Wohnort: Berlin

Re: Hylafax Installation scheitert in Debian

Beitrag von JTH » 15.10.2022 20:53:13

Wär nett, wenn du vollständige, längere Ausgaben postest, solange das Problem nicht genauer eingegrenzt ist. Hilft aus der Ferne einfach beim Orientieren. Und manchmal unterschlägt man durch Verkürzen unbewusst einen Hinweis zur Problemlösung.

Xantorix hat geschrieben: ↑ zum Beitrag ↑
15.10.2022 19:35:40
"faxsetup" bricht immer noch hier ab:

Code: Alles auswählen

Probing for best speed to talk to modem: 38400
Nochmal: Was wird sonst davor ausgegeben? Z.B. Hinweise auf ein Device, das/dessen Vorhandensein man genauer anschauen könnte?

Xantorix hat geschrieben: ↑ zum Beitrag ↑
15.10.2022 19:35:40

Code: Alles auswählen


Okt 15 19:31:29 omv-office asterisk[2401]: [Oct 15 19:31:29] ERROR[2401]: loader.c:2396 load_modules: cdr_radius declined to load.
[…]
Okt 15 19:31:29 omv-office asterisk[2401]: Asterisk Ready.
Okt 15 19:31:29 omv-office systemd[1]: Started Asterisk PBX.
Das liest sich ja jetzt eher „schlechter“ als vorher. Was wurde geändert?

Xantorix hat geschrieben: ↑ zum Beitrag ↑
15.10.2022 18:13:45
Habe gerade mal zum testen efax auf den Server gemacht.

Also das IAXmodem funktioniert und es lässt sich auch mit efax ein Fax absenden.

[…] aber wenn es mit efax geht vermute ich den Fehler in hylafax.
Okay, ja, das sieht dann erstmal nach letzterem aus.


faxsetup ist einfach ein großes Bash-Skript. Zum Debuggen könntest du es mal mit -x ausführen, dann sieht man, bei welchen exakten, zuletzt ausgeführten Schritten es hängt:

Code: Alles auswählen

~# bash -x faxsetup
plus Argumente für faxsetup, falls normalerweise übergeben.
Manchmal bekannt als Just (another) Terminal Hacker.

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 15.10.2022 20:59:22

Hab es so gemacht. Wo sehe ich da jetzt was? Hängt wieder. An der konsole sehe ich nichts anderes.

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 15.10.2022 21:10:45

JTH hat geschrieben: ↑ zum Beitrag ↑
15.10.2022 20:53:13
Das liest sich ja jetzt eher „schlechter“ als vorher. Was wurde geändert?
Ich habe in der sip.conf bei register die Domain fritz.box durch die IP ersetzt.

Hier komplett nach " bash -x faxsetuo "

Code: Alles auswählen

++ basename faxsetup
+ readonly name=faxsetup
+ name=faxsetup
+ mount -o bind /etc/hylafax /var/spool/hylafax/etc
+ /usr/lib/hylafax/bin/faxsetup

Setup program for HylaFAX (tm) 6.0.7.

Created for x86_64-pc-linux-gnu on Wed, 13 Jan 2021 13:00:13 +0000.

Reading cached parameters from /var/spool/hylafax/etc/setup.cache.

Found base64 encoder: /bin/base64
Found Quoted-Printable encoder: qp-encode
Found mimencode for compatibilty: mimencode
Checking system for proper server configuration.


Warning: /etc/hylafax/getty-link does not exist or is not an executable program!

The file:

    /etc/hylafax/getty-link

does not exist or this file is not an executable program.  The
HylaFAX software optionally uses this program and the fact that
it does not exist on the system is not a fatal error.  If the
program resides in a different location and you do not want to
install a symbolic link for /etc/hylafax/getty-link that points to your program
then you must reconfigure and rebuild HylaFAX from source code.


Warning: /etc/hylafax/vgetty-link does not exist or is not an executable program!

The file:

    /etc/hylafax/vgetty-link

does not exist or this file is not an executable program.  The
HylaFAX software optionally uses this program and the fact that
it does not exist on the system is not a fatal error.  If the
program resides in a different location and you do not want to
install a symbolic link for /etc/hylafax/vgetty-link that points to your program
then you must reconfigure and rebuild HylaFAX from source code.


Warning: /etc/hylafax/egetty-link does not exist or is not an executable program!

The file:

    /etc/hylafax/egetty-link

does not exist or this file is not an executable program.  The
HylaFAX software optionally uses this program and the fact that
it does not exist on the system is not a fatal error.  If the
program resides in a different location and you do not want to
install a symbolic link for /etc/hylafax/egetty-link that points to your program
then you must reconfigure and rebuild HylaFAX from source code.

Make /var/spool/hylafax/bin/ps2fax a link to /var/spool/hylafax/bin/ps2fax.gs.


Make /var/spool/hylafax/bin/pdf2fax a link to /var/spool/hylafax/bin/pdf2fax.gs.

Update /var/spool/hylafax/status/any.info.

	HylaFAX configuration parameters are:

	[1] Init script starts faxq:		yes
	[2] Init script starts hfaxd		yes
	[3] Start paging protocol:		no
Are these ok [yes]? 

Modem support functions written to /var/spool/hylafax/etc/setup.modem.
Configuration parameters written to /var/spool/hylafax/etc/setup.cache.

Restarting HylaFAX server processes.
Should I restart the HylaFAX server processes [yes]? 

/etc/init.d/hylafax start
Starting hylafax (via systemctl): hylafax.service.

You do not appear to have any modems configured for use.  Modems are
configured for use with HylaFAX with the faxaddmodem(8) command.
Do you want to run faxaddmodem to configure a modem [yes]? 
Serial port that modem is connected to [ttyS0]? ttyIAX0

Ok, time to setup a configuration file for the modem.  The manual
page config(5) may be useful during this process.  Also be aware
that at any time you can safely interrupt this procedure.

Reading scheduler config file /var/spool/hylafax/etc/config.

No existing configuration, let's do this from scratch.

Country code [1]? 49
Area code [415]? 6xxx
Phone number of fax modem [+1.999.555.1212]? +49.6xxx.8xxx6
Local identification string (for TSI/CIG) ["NothingSetup"]? "Firmenname"
Long distance dialing prefix [1]? 0
International dialing prefix [011]? 00
Dial string rules file (relative to /var/spool/hylafax) [etc/dialrules]? 
Tracing during normal server operation [1]? 
Tracing during send and receive sessions [11]? 
Protection mode for received facsimile [0600]? 
Protection mode for session logs [0600]? 
Protection mode for ttyIAX0 [0600]? 
Rings to wait before answering [1]? 
Modem speaker volume [off]? 
Command line arguments to getty program ["-h %l dx_%s"]? 
Pathname of TSI access control list file (relative to /var/spool/hylafax) [""]? 
Pathname of Caller-ID access control list file (relative to /var/spool/hylafax) [""]? 
Tag line font file (relative to /var/spool/hylafax) [etc/lutRS18.pcf]? 
Tag line format string ["From %%l|%c|Page %%P of %%T"]? "Von %%l|%c|Seite %%P von %%T"
Time before purging a stale UUCP lock file (secs) [30]? 
Hold UUCP lockfile during inbound data calls [Yes]? 
Hold UUCP lockfile during inbound voice calls [Yes]? 
Percent good lines to accept during copy quality checking [95]? 
Max consecutive bad lines to accept during copy quality checking [5]? 
Max number of pages to accept in a received facsimile [25]? 
Syslog facility name for ServerTracing messages [daemon]? 
Set UID to 0 to manipulate CLOCAL [""]? 
Use available priority job scheduling mechanism [""]? 

The non-default server configuration parameters are:

CountryCode:		49
AreaCode:		6xxx
FAXNumber:		+49.6xxx.8xxx6
LongDistancePrefix:	0
InternationalPrefix:	00
DialStringRules:	etc/dialrules
SessionTracing:		11
RingsBeforeAnswer:	1
SpeakerVolume:		off
GettyArgs:		"-h %l dx_%s"
LocalIdentifier:	        "Firmenname"
TagLineFont:		 etc/lutRS18.pcf
TagLineFormat:		"Von %%l|%c|Seite %%P von %%T"
MaxRecvPages:		25

Are these ok [yes]? 

Now we are going to probe the tty port to figure out the type
of modem that is attached.  This takes a few seconds, so be patient.
Note that if you do not have the modem cabled to the port, or the
modem is turned off, this may hang (just go and cable up the modem
or turn it on, or whatever).

Probing for best speed to talk to modem: 38400

P.S. Jetzt sehe ich die bemängelten links. Leider habe ich davon keine Ahnung. Warum wurden die nicht mit hylafax installiert?

Benutzeravatar
Tintom
Moderator
Beiträge: 3036
Registriert: 14.04.2006 20:55:15
Wohnort: Göttingen

Re: Hylafax Installation scheitert in Debian

Beitrag von Tintom » 15.10.2022 22:24:59

Passt der Pfad des Modems zu dem in der Konfigurationsdatei?

Xantorix
Beiträge: 177
Registriert: 27.01.2018 13:33:06

Re: Hylafax Installation scheitert in Debian

Beitrag von Xantorix » 15.10.2022 22:39:43

Ist ein virtuelles Modem. Iaxmodem. Ich schau morgen mal. Danke.

Benutzeravatar
Tintom
Moderator
Beiträge: 3036
Registriert: 14.04.2006 20:55:15
Wohnort: Göttingen

Re: Hylafax Installation scheitert in Debian

Beitrag von Tintom » 16.10.2022 10:45:31

Das habe ich verstanden, mir ging es darum, dass dort steht Serial port that modem is connected to [ttyS0]? ttyIAX0 und daher die Frage wie sieht die Konfigurationsdatei des Softmodems aus. Weiterhin: Stimmen Gruppenzugehörigkeit/Berechtigungen? In der Richtung würde ich jetzt zunächst schauen.

Antworten